ADS-B DIY Antenna

Status
Not open for further replies.
If RPi is rebooted, ModSDeco2 does NOT start automatically and should be started manually. I have added an script to start ModeSDeco2 at boot.

Create a script file
Code:
cd /etc/init.d
sudo nano modesdeco2.sh
This will create a new blank file modesdeco2.sh in folder /etc/init.d
Copy paste following code in the new file and save the file (ctrl+o)
Code:
killall dump1090
killall dump1090-mutability
cd /usr/share/modesdeco2/
./modesdeco2 --gain 49.6 --avrmlat 30002 --beast 30005 --rbs --msg 30003 --web 8080 --location 43.58:-79.62 --agc on &

Make this file executable by following command
Code:
sudo chmod +x /etc/init.d/modesdeco2.sh
sudo update-rc.d modesdeco2.sh defaults

Now reboot
After reboot check status
Code:
sudo service fr24feed status  #FlightRadar24 status
sudo service piaware status  # Piaware status
sudo cat /tmp/piaware.out  #Flightaware feeder log file
sudo cat /tmp/pfclient.log  #Plane Finder feeder
 
Last edited:
Hi,

I receiving less planes with modesdeco2, screenshots with 2 minutes interval.

Modesdeco2

./modesdeco2 --gain 49.6 --avrmlat 30002 --beast 30005 --rbs --msg 30003 --web 8080 --location 52:5 --agc on

View attachment 1043

Dump1090-mut

# RTLSDR gain in dB.
# If set to "max" (the default) the maximum supported gain is used.
# If set to "agc", the tuner AGC is used to set the gain.
GAIN="max
# RTLSDR frequency correction in PPM
PPM="0"
# If yes, enable sampling at 2.4MHz. Otherwise, 2.0MHz is used.
OVERSAMPLE="yes"
# If yes, enables phase-enhancement of message
PHASE_ENHANCE="yes"
#
# Decoding options
# If yes, fixes messages with correctable CRC errors.
FIX_CRC="yes"
# If yes, enables aggressive fixes to damaged messages.
# Use with caution - it can increase the rate of undetected errors.
AGGRESSIVE="yes"


View attachment 1044
I am also seeing less planes with modesdeco2 than with dump1090 or dump-mutablity.
 
The reason you see less planes is most likely that you have Gain set to max. Check gain in ADSB# or RTL1090 and watch when you get the maximum numbers and set Modesdeco gain the same. I have been using Modesdeco a couple of weeks but recently stopped to use it as it give many false entries. I left my radar unattended for two days and when I came home and checked my logfile for new regs I had over 300 new from all kind of countries in Africa and South America...
 
The reason you see less planes is most likely that you have Gain set to max. Check gain in ADSB# or RTL1090 and watch when you get the maximum numbers and set Modesdeco gain the same. I have been using Modesdeco a couple of weeks but recently stopped to use it as it give many false entries. I left my radar unattended for two days and when I came home and checked my logfile for new regs I had over 300 new from all kind of countries in Africa and South America...

They fixed ghost planes in the latest release :)
 
Maybe agc set the hw gain to 0db (cause you have a strong signal due to near amplifier) and this will make sensitivity to drop.

Try to start the command as I wrote it originally. Here seems to works very well!
 
Maybe agc set the hw gain to 0db (cause you have a strong signal due to near amplifier) and this will make sensitivity to drop.

Try to start the command as I wrote it originally. Here seems to works very well!
In the command you gave, gain is at two locations: first one right at start "--gain 49.6" sets it to maximum, second one "--gain agc" is executed at the end, it sets it back to agc. By the way there is an "&" at the end of command line. What it does?
 
.....Try to start the command as I wrote it originally. Here seems to works very well!
I now recall that when I installed and configured modesdeco2 manually without the starting script, I have put both 49.6 and agc, exactly as you have written, and it seemed ok, but it was late night, when there are very few planes in air. Later in morning, when I was preparing auto start script midesdeco2.sh, I thought 49.6 will be overriden by last parameter agc, so omitted it. Then after a while I looked to map, it was like late night though it was 8 in mrning now, lot of planes flying. I cursed modesdeco2 :mad: , shutdown RPi, removed microSD #1, inserted microSD#2 with old faithful piaware + dump1090, and rebooted Pi, and all was back to normal!

I am not at home now, replying from phone. When home, I will edit starting script file "modesdeco2.sh" and add "--gain 49.6" right in the begining of arguments,, save and reboot. Hope things will be ok then.

EDIT: In my yestrtday's post, I have now added in the script "modesdeco2.sh", argument "--gain 49.6" at the start of arguments, so that anyone using it does not get into problem like me and bramj .
 
Last edited:
In the command you gave, gain is at two locations: first one right at start "--gain 49.6" sets it to maximum, second one "--gain agc" is executed at the end, it sets it back to agc. By the way there is an "&" at the end of command line. What it does?

& at the end just put the process in the background so you can close the shell and it continues to run.

I now recall that when I installed and configured modesdeco2 manually without the starting script, I have put both 49.6 and agc, exactly as you have written, and it seemed ok, but it was late night, when there are very few planes in air. Later in morning, when I was preparing auto start script midesdeco2.sh, I thought 49.6 will be overriden by last parameter agc, so omitted it. Then after a while I looked to map, it was like late night though it was 8 in mrning now, lot of planes flying. I cursed modesdeco2 :mad: , shutdown RPi, removed microSD #1, inserted microSD#2 with old faithful piaware + dump1090, and rebooted Pi, and all was back to normal!

I am not at home now, replying from phone. When home, I will edit starting script file "modesdeco2.sh" and add "--gain 49.6" right in the begining of arguments,, save and reboot. Hope things will be ok then.

EDIT: In my yestrtday's post, I have now added in the script "modesdeco2.sh", argument "--gain 49.6" at the start of arguments, so that anyone using it does not get into problem like me and bramj .

Let me know! I'll investigate tomorrow, now time to sleep


EDIT: From dev forum:

- In ModesD2 is usually better not to use the --agc for RTL. The program has internal gain control algorithm - separately for receiving chip and RTL. It constantly monitors the level of the signal and noise and calculates the instantaneous value threshold. Adding to this process no way associated --agc from dongle usually only prevents. Although there are exceptions for specific antenna setup.

- For the same reason, the value of --gain for receiving chip R820T is desirable to establish fixed and maximum (48 or 49.6 dB). The program is able to make the necessary gain adaptation themselves.
 
Last edited:
I just learned something about VRS. I never thought about setting the mode in Options. I just left it at the default "Base Station" I read over at FlightAware someone say to set mode AVR or Beast and port 30005. I did that and it seems like I'm getting more messages per second.
 

Attachments

  • AVR or Beast.png
    AVR or Beast.png
    27.8 KB · Views: 57
Changed settings of modesdeco2 (addeded argument --gain 49.6 at start of arguments list), rebooted, number of planes half of dump1090-mut. see screenshots.
Stopped using modesdeco2. Now using dump1090-mutablity.
modesdeco vs dump mut 1.PNG . modesdeco vs dump mut 2.PNG
 
I receive more messages with modes2deco2 :( My stats on FA and FR increased in messages and positions reports since i switched to modesdeco2
1. Which OS you are using, Windows, Raspbian, or other versions of linux?

2. Have you purchsed helium filled baloons recently? :D
 
Status
Not open for further replies.
Back
Top