ADS-B DIY Antenna

Status
Not open for further replies.

jepolch

Active Member
It's to reduce the chance that dump1090 starts dropping samples if there is other stuff running that's competing for CPU. For example it helps while you're running a package upgrade or similar. If the package upgrade is short on CPU it just runs a bit slower. If dump1090 is short on CPU then you start losing data. Negative niceness does what you'd expect - it makes a process "not nice" and more likely to get CPU :)
Thanks for that nice reply. ;) I understand.
 

jepolch

Active Member
It's complicated! I only worked out exactly what was going on recently.

There are three stages of controllable amplification in the dongle: the LNA, the mixer, and the IF VGA - that amplify the signal, in that order.

When you set manual gain, that sets the LNA and mixer gain to max, and sets the IF gain to a fixed value.

When you ask for AGC, that puts the LNA and mixer gain under the control of the AGC, and sets the IF gain to a different - higher - fixed value compared to what you get with manual gain. Then the AGC ramps all the gain that it controls - that is, the LNA and mixer - up to maximum because it doesn't deal with ADS-B signals very well.

So in both cases, the LNA/mixer gain settings end up the same. But because the IF gain is set differently in the two cases, the total gain that you get when you ask for AGC is slightly higher than what you get when you ask for max manual gain.

Really, librlsdr should be smarter about how it sets the IF gain, and let you increase it if you need to. I have some work along those lines to merge.. but a project for another day :)
That, on the other hand, went a little over my head. I worked in IT for years - before it was called IT and when we wrote scripts on stone tablets. :D Using the Pi brings back fond memories of my Solaris Unix days, but also reminds me how rusty I am.
 

jepolch

Active Member
How did you get into see this on the Pi? Also whats the command to get into the config of the Dump1090-Mut? To see if 2.4 is on and the other settings.. Thanks.
When you get on the command line, type the word 'top' (without the quotes, of course). You'll see a screen as I showed in a post above (also attached here). To quit top, type the letter q. To configure dump1090-mutability, type 'sudo dpkg-reconfigure dump1090-mutability'. Be really careful what you enter there. If you keep hitting enter you can scroll through the pages without changing anything.
 

Attachments

Sjacket99

Member
When you get on the command line, type the word 'top' (without the quotes, of course). You'll see a screen as I showed in a post above (also attached here). To quit top, type the letter q. To configure dump1090-mutability, type 'sudo dpkg-reconfigure dump1090-mutability'. Be really careful what you enter there. If you keep hitting enter you can scroll through the pages without changing anything.

ok.. Thanks. I went into this way../etc/default/dump1090-mutability... Just used nano. But yea I don't want to screw something up.
 

Sjacket99

Member
When you get on the command line, type the word 'top' (without the quotes, of course). You'll see a screen as I showed in a post above (also attached here). To quit top, type the letter q. To configure dump1090-mutability, type 'sudo dpkg-reconfigure dump1090-mutability'. Be really careful what you enter there. If you keep hitting enter you can scroll through the pages without changing anything.

I went into it and changed it from max gain to agc.. to see what that may do.
 

ab cd

Senior Member
FWIW, "agc" is identical to -10 (if you say "agc", the init script turns that into --gain -10 !)

AGC seems to be a good choice for unamplified antennas at the moment - it is not the autogain part that it useful, it's that the total gain in that configuration is actually slightly higher than what you get with "max". (I need to find some time to sort out librtlsdr and fix that oddity so you can get direct access to the higher gain setting).
First I tried following settings, but still load is high
Code:
sudo dpkg-reconfigure dump1090-mutability 
#entered agc in gain setting
Then i tried this, but load still high.
Code:
cd /etc/default/ 
sudo dump1090-mutability --enable-agc 
sudo reboot
 
Last edited:

bramj

Member
I change it like this , no need for reboot and "dpkg-reconfigure"

Editing dump1090-mutability configuration

Code:
sudo nano /etc/default/dump1090-mutability
look for Gain setting section and change it

# RTLSDR gain in dB.
# If set to "max" (the default) the maximum supported gain is used.
# If set to "agc", the tuner AGC is used to set the gain.
GAIN="agc"

Save file CTRL+O
Enter and exit CRTL+X

Reload config

Code:
sudo /etc/init.d/dump1090-mutability force-reload
or
Code:
 sudo /etc/init.d/dump1090-mutability restart

[ ok ] Restarting dump1090-mutability daemon: dump1090-mutability.
 

xforce30164

Active Member
My new raspberry pi 2 arrived yesterday with the mail. Currently setting it up to run experimental dump1090 builds on. But will be used later as secondary receiver. Ill probably leave my first raspberry at my parents house who live very close to schiphol.
my other cables and dongles are scheduled to arrive between 4 and 15 march or something like that so that will be a bit of a wait :p

been playing around a bit with an idea. got it working in very simple version.

I made a simple "menu/top bar" that I can use to select dump1090 window, Raspberry monitor page or open the flightaware/planefinder stats pages for my receiver. just used some basic html frames and added an index.html file, so I type only the ip-addres of my raspberry
dump1090 menu.png
 
Last edited:

jepolch

Active Member
Bought one of these antennas:

http://www.ebay.com/itm/BRAND-NEW-Aircraft-Transponder-DME-ADS-B-Post-Antenna-/140958325304

and installed it using a metal chassis from an old DVD player and the results were.....DISAPPOINTING. My home made ground plane (spider) antenna works much much better.
That's too bad. You'd think a real ADS-B transmitting antenna would work well for a receiver. The length is a mystery to me, though. It's shorter than our normal 69 mm antennas. Did you try it with an amp?
 

PeterPlane

New Member
That's too bad. You'd think a real ADS-B transmitting antenna would work well for a receiver. The length is a mystery to me, though. It's shorter than our normal 69 mm antennas. Did you try it with an amp?
No amp - I don't have one currently. I intend to try it on a tin-can before I give up on it completely.
 

giacomo1989

Member
Yep, that looks fairly normal.
Thanks! I've a question for you.
Does the installed rtl-sdr driver (on linux) makes some difference (osmocom git vs keerned git repo) ? Or dump1090 already includes all the drivers it needs to access the device?
 

obj

New Member
Thanks! I've a question for you.
Does the installed rtl-sdr driver (on linux) makes some difference (osmocom git vs keerned git repo) ? Or dump1090 already includes all the drivers it needs to access the device?
It uses whatever shared library the dynamic linker picks up, so yes, potentially there is a difference there.

You can make it use a specific version by setting LD_LIBRARY_PATH. "ldd `which dump1090-mutability`" will tell you what it's using.
 

jepolch

Active Member
No amp - I don't have one currently. I intend to try it on a tin-can before I give up on it completely.
It surely needs some sort of ground plane. I guess the body of the aircraft acts as a ground plane. Maybe mount it on a metal plate, I'd try something larger than a tin can due to its size. Maybe an aluminum pie plate or something like that.
 

giacomo1989

Member
It uses whatever shared library the dynamic linker picks up, so yes, potentially there is a difference there.

You can make it use a specific version by setting LD_LIBRARY_PATH. "ldd `which dump1090-mutability`" will tell you what it's using.
What do you suggest to use?
 

obj

New Member
No, that's an unmaintained version with experimental changes, like it says.

Use this one: https://github.com/mutability/librtlsdr/tree/pi-package
This is the package distributed on repo.mutability.co.uk; it is just osmocom + debian packaging based on wheezy-backports, built for Raspbian.

If you're not using Raspbian, just use your distribution's packaging of librtlsdr.

Are you having problems with the standard package?
 

giacomo1989

Member
No, that's an unmaintained version with experimental changes, like it says.

Use this one: https://github.com/mutability/librtlsdr/tree/pi-package
This is the package distributed on repo.mutability.co.uk; it is just osmocom + debian packaging based on wheezy-backports, built for Raspbian.

If you're not using Raspbian, just use your distribution's packaging of librtlsdr.

Are you having problems with the standard package?
http://repo.mutability.co.uk/raspbian/ wheezy/rpi rtl-sdr armhf 0.5.4~git-1

Thanks! Don't know if I have problems :) I'm just looking for an higher message rate :)
 
Status
Not open for further replies.
Top