Automated Installation of Dump1090-Mutability, Data Feeders, and Performance Graphs

W1PAC

New Member
Hello all,

Kind of semi-necrobumping this post here, but I installed the planefinder client using Joe's script.

Anyways, got a notification that my planefinder feed was down earlier today. Took a look at port 30053 and sure enough, it's offline. On the other hand though, FlightAware is still feeding perfectly fine. FR24 also.

I thought a simple reinstall of the Planefinder client using Joe's script would work... except I can't reinstall via the script, there's no option to.

Any ideas?
 

ab cd

Senior Member
(1) First purge current install
Code:
sudo dpkg --purge pfclient


(2) After purging, reinstall by running Joe's scrip, OR manually by following commands

Code:
wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb 

sudo dpkg -i pfclient_4.1.1_armhf.deb
 

W1PAC

New Member
Purged, reinstalled via Joe's script. Still getting a connection refused when it asks me to configure the client via the webpage after install.
 

W1PAC

New Member
Code:
This site can’t be reached
"IP address of the Pi" refused to connect.
ERR_CONNECTION_REFUSED
Anwyays, I need to get ready for work. I'll try any suggestions you have tomorrow. :)
 

ab cd

Senior Member
You should not use "IP-of-Pi" as is.

You should replace "IP-of-Pi" by IP address you use to SSH to Pi.

For example, my Pi's "IP-of-Pi" is 192.168.0.21, I type following address in web browser to go to Planefinder settings:

192.168.0.21:30053


Ok, what do you get at
IP-of-Pi:8754
 
Last edited:

FUNG SAI HOU

New Member
Hello all,

Kind of semi-necrobumping this post here, but I installed the planefinder client using Joe's script.

Anyways, got a notification that my planefinder feed was down earlier today. Took a look at port 30053 and sure enough, it's offline. On the other hand though, FlightAware is still feeding perfectly fine. FR24 also.

I thought a simple reinstall of the Planefinder client using Joe's script would work... except I can't reinstall via the script, there's no option to.

Any ideas?
Hi W1PAC,

In what Single Board Computer and what OS you currently installed? Which version of dump1090 you chosen to install using the Joe's script? Then Mr. ab cd might have more detail / info to assist you on this matter.

73.
 

ab cd

Senior Member
Open file pfclient-config.json for editing

Code:
sudo nano /etc/pfclient-config.json
Delete all entries by repatedly pressing Ctrl+k
(Unconfigured file will have only {} )

Copy paste following.
Replace xx.xxx, yy.yyyy, and zzzzzzzzzzz by their actual values. While replacing xxx yyy zzz, take care not to delete any of " , :


Code:
{
"tcp_address":"127.0.0.1",
"tcp_port":"30005",
"select_timeout":"10",
"data_upload_interval":"10",
"connection_type":"1",
"aircraft_timeout":"30",
"data_format":"1",
"latitude":"xx.xxxx",
"longitude":"yy.yyyy",
"sharecode":"zzzzzzzzzzzz"
}
After copy-paste save file Ctrl+o and Close file Ctrl+x
Reboot RPi
Code:
sudo reboot
Now check status
Code:
sudo systemctl status pfclient -l
Check map
IP-of-Pi:30053
 
Last edited:

ab cd

Senior Member
Code:
This site can’t be reached
"IP address of the Pi" refused to connect.
ERR_CONNECTION_REFUSED

How are you accessing your Pi?

(A) By connecting a monitor, keyboard and mouse to RPi

OR

(B) By SSH from your Desktop/Laptop

.
 

W1PAC

New Member
Open file pfclient-config.json for editing

Code:
sudo nano /etc/pfclient-config.json
Delete all entries by repatedly pressing Ctrl+k
(Unconfigured file will have only {} )

Copy paste following.
Replace xx.xxx, yy.yyyy, and zzzzzzzzzzz by their actual values. While replacing xxx yyy zzz, take care not to delete any of " , :


Code:
{
"tcp_address":"127.0.0.1",
"tcp_port":"30005",
"select_timeout":"10",
"data_upload_interval":"10",
"connection_type":"1",
"aircraft_timeout":"30",
"data_format":"1",
"latitude":"xx.xxxx",
"longitude":"yy.yyyy",
"sharecode":"zzzzzzzzzzzz"
}
After copy-paste save file Ctrl+o and Close file Ctrl+x
Reboot RPi
Code:
sudo reboot
Now check status
Code:
sudo systemctl status pfclient -l
Check map
IP-of-Pi:30053
That fixed it! Granted it's quiet time for the BOS area at the moment so no activity on the screen, guess I'll wait to first BOS flights begin their early morning takeoffs.
 
Top