DNS problem

#1
I have a problem currently with my ISP that causes the router to lose the DNS every day, when this happens the Planefinder feeder stops. I have changed all my devices in the house to use Google (8.8.8.8) and they are unaffected. I cannot change DNS in the router as it is locked out.

Can I change the DNS that Planefinder is using, I think it is pointing at the router now (192.168.0.1).

This is on a Raspberry Pi 2.
 

Lee Armstrong

Administrator
Staff member
#2
We use Cloudflare at Plane Finder and so their new 1.1.1.1 DNS service is ideal as the lookup will be instant.

I would never suggest letting the router "proxy" the DNS requests and would set the DHCP to serve out the public addresses for DNS servers instead of the router.
 
#3
Thanks Lee, I looked at Cloudflare and will give it a try. I have edited /etc/dhcp/dhclient.conf in the Pi as follows:

#prepend domain-name-servers 1.1.1.1,1.0.0.1;

I hope that will do the job.
 
#4
Seems to be running OK at the moment, the DNS is holding but the Planefinder feeder stopped with the error "Setting NTP sync state to unsynced".

I had to restart pfclient to continue.
 
#6
It had stopped feeding for about three hours before I noticed. It's a Sky hub, not what I would have chosen but tied to the account.
 
#8
@Lee Armstrong

I've reached a bit of a dilemma now, Running Planefinder on a PiAware system it's impossible to keep both running with my ISPs DNS problem.

FlightAware uses Google DNS that bypasses my ISPs problem. Planefinder uses my router (my iSPs DNS) and this will fail every few hours. I cannot get into the router to change the DNS and I have no way to change it in Planefinder. I tried using a VPN and it works for Planefinder but then FlightAware starts throwing up problems.

Since my ISP is in no hurry to fix this problem I don't see any solution. Is there any way I can change DNS for Planefinder?
 
#10
I'm not sure how to do that. I have tried a couple of methods I Googled but they didn't seem to stick.

After some more Googling and a bit of searching I have found /etc/resolvconf.conf which has an entry for DNS. It seems to survive a reboot. Have to see if it holds up, I have set it for 1.1.1.1
 
Last edited:
Top