Double Checking: PI-FLightaware Package Functionality..

#2
Just sign up install the planefinder client, and away you go.

Planefinder client settings will be something like
Tcp Address 127.0.0.1
Tcp Port 30005
Data Format Beast

If you want to get the most, it is worth looking at dump1090 mutability. Switch off the piaware dump1090 and install and run that instead. The oversampling will give you extra messages, plus if you configure the inbound port as 30104 you will see flightaware MLAT traffic on your planefinder page! Well worth it.
 
Last edited:
#4
I dont fully understand how to get data inbound on port 30104...although I did tell the config to beast mode input on that port.

Also, does the pro stick require a ground plane? Right now, it's zip tied to a deck chair on my patio on the 19th floor here...not bad, not the best, but it is what it is..about 30min after unboxing it.

I am rxing packets.
 
#6
If you SSH to your PI and run the command sudo piaware-config -show
you should see something like the following if MLAT is correctly setup.

Code:
pi@piaware ~ $ sudo piaware-config -show
contents of piaware config file '/root/.piaware':
autoUpdate 1
mlat 1
mlatResults 1
mlatResultsFormat {beast,connect,localhost:30104 basestation,listen,31003}
password yourflightawarepassword
user fausername@email.address
If MLAT is 0 or the other settings are missing, run these commands (at own risk)

Code:
sudo piaware-config -mlat 1
sudo piaware-config -mlatResults 1
sudo piaware-config -mlatResultsFormat "beast,connect,localhost:30104 basestation,listen,31003"
sudo piaware-config -restart
See how that goes and let us know.

Hopefully you will see some blue planes like below. Although this will depend on having three or more receivers doing the same within range.

pfclient.png
 
#8
Ya I dont get any blue planes in the planefinder map, or the Dump1090-mu map.

My settings are with yours..

I set my lat/lon and elevation accurately using my aviation GPS receiver...its way off from google maps, but Im not somehow surprised.
 
#9
Flightaware says:

Multilateration (MLAT): Supported / Enabled (synchronized with 106 nearby receivers)

Buuuut...I see no MLAT birds in my maps.