dump1090-mutability v1.15~dev v Stretch

#1
Hi all
New member been doing the rounds with adsb for few years
i recently upgraded to stretch on pi, but now my "dump1090-mutability v1.15"
fails to do anything
would it be rtl usb libraries need looking at as im baffled
any help would be appreciated
linuxnobb

john
 

ab cd

Senior Member
#2
@SuffolkcHAT
Yesterday, after seeing your post, I wrote Raspbian Stretch on microSD card, and installed dump1090-mutability v1.15~dev. I found the dump1090-mutability does not work. I posted the issue in Flightaware forums.

https://discussions.flightaware.com...ility-v1-15-dev-does-not-work/25009?u=abcd567


Today afternoon I contacted Oliver Jowett, the author of dump1090-mutability, and got his reply as follows:

"I am travelling for the next week, will look once I’m back".

We have to wait for a week or two for the solution of issue "failure of dump1090-mutability when installed on Raspbian STRETCH".
 
#4
Hi John!

Had the same problem but have already an answer:

sudo apt-get update
sudo apt-get install dirmngr

Then it will automagically work... :)
 

ab cd

Senior Member
#5
Hi John!

Had the same problem but have already an answer:

sudo apt-get update
sudo apt-get install dirmngr

Then it will automagically work... :)
Installation of package "dirmngr" DOES NOT solve the problem for installation of dump1090-mutability on Raspbian Stretch.

Installation of package "dirmngr" is actually solution for the failure of installation of Flightradar24 data feeder on Stretch by bash script sudo bash -c "$(wget -O - http://repo.feed.flightradar24.com/install_fr24_rpi.sh)".

 
#6
Ok @ab cd!

Actually I´m running dump1090-mutability under Stretch

The first line of a "top" command is:

609 dump1090 15 -5 29032 10616 2152 R 26.6 1.1 711:48.79 dump1090-mutabi


Linux raspberrypi 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux
 
#8
under my /install-dump1090/ directory I have the debs:


dump1090-mutability_1.15~dev_armhf.deb
dump1090-mutability-dbgsym_1.15~dev_armhf.deb


I had no inconsistencies and got it installed.
 
#9
-rw-r--r-- 1 root root 603604 Aug 28 15:40 dump1090-mutability_1.15~dev_armhf.deb
-rw-r--r-- 1 root root 239558 Aug 28 15:40 dump1090-mutability-dbgsym_1.15~dev_armhf.deb
 
#10
The only difference among your tutorial and what I did is the install of rtl-dsr separately, before all the process of installing dump1090-mutability_1.15~dev package.
Other than that both methods are alike.

I always do like that.

Hope that helps!
 
Last edited:
#13
Crunching happily...

pi@raspberrypi:~ $ sudo systemctl status piaware -l
● piaware.service - FlightAware ADS-B uploader
Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset:
Active: active (running) since Mon 2017-08-28 00:27:02 UTC; 2 days ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 561 (piaware)
CGroup: /system.slice/piaware.service
├─561 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusf
├─704 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --n
└─713 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localho

Aug 30 21:29:06 raspberrypi piaware[561]: mlat-client(713): Aircraft: 8 of 11 Mo
Aug 30 21:32:40 raspberrypi piaware[561]: 234950 msgs recv'd from dump1090-mutab
Aug 30 21:37:40 raspberrypi piaware[561]: 235310 msgs recv'd from dump1090-mutab
Aug 30 21:42:40 raspberrypi piaware[561]: 235723 msgs recv'd from dump1090-mutab
Aug 30 21:44:06 raspberrypi piaware[561]: mlat-client(713): Receiver status: con
Aug 30 21:44:06 raspberrypi piaware[561]: mlat-client(713): Server status: syn
Aug 30 21:44:06 raspberrypi piaware[561]: mlat-client(713): Receiver: 44.6 msg
Aug 30 21:44:06 raspberrypi piaware[561]: mlat-client(713): Server: 0.1 kB/
Aug 30 21:44:06 raspberrypi piaware[561]: mlat-client(713): Results: 39.5 posit
Aug 30 21:44:06 raspberrypi piaware[561]: mlat-client(713): Aircraft: 10 of 15 M
lines 1-20/20 (END)
 

ab cd

Senior Member
#14
@jaxxtheone:

I have thrice made fresh install of Raspbian Stretch and dump1090-mutability during last three weeks, and during last fresh install few days ago, have even installed package "dirmngr", but dump1090-mutability, although running, failed to give any output to map or Piaware.

When did you make this install which is running successfully? If it is very recent, then there is a likelyhood that Oliver Jowett (author of dump1090-mutability) has fixed the bug, and you installed it after the bug fix.

Tomorrow I will format my micriSD card, and make a fresh install Stretch and dump1090-mutability to see if the bug has been fixed by Oliver Jowett.
 
#15
@ab cd

Hope you have success.

As I said the only difference from your tutorial is that, prior of installing dump1090-mutability_1.15~dev, I did a rtl-sdr install.

Used:

# sudo apt-get install -y git cmake libusb-1.0-0.dev build-essential
# git clone git://git.osmocom.org/rtl-sdr.git
# cd rtl-sdr/
# mkdir build
# cd build
# cmake ../
# make
# sudo make install
# sudo ldconfig

Then:

# chmod +x /home/pi/rtl-sdr/build/rtl_tcp.sh
# sudo cp /home/pi/rtl-sdr/rtl-sdr.rules /etc/udev/rules.d
# sudo bash -c 'echo "blacklist dvb_usb_rtl28xxu" > /etc/modprobe.d/dvb_usb_rtl28xxu.conf'

And finally:

# sudo systemctl enable /home/pi/rtl-sdr/build/rtl_tcp.service
# sudo init 6


After that, I used your tutorial
 
Last edited:
#16
@ab cd

As per your question, I´ve done my new install last 27th. August, Sunday.
And, yes, two of then. I have a third one about 50 miles away but this one is under Jessie .
 

ab cd

Senior Member
#18
@jaxxtheone:
Thank you for posting the workaround.

Yes, you are right. It is the problem of rtl-sdr package. This is also confirmed by another person Radstand in Flightaware forum.

You have solved it by NOT using the pre-built package rtl-sdr by method "apt-get install rtl-sdr". Instead you have built it using source code.

Another person Radstad has solved this problem by adding missing entries in blacklist files "rtl-sdr-blacklist.conf" and "rtl-sdr.rules"

https://discussions.flightaware.com...90-mutability-v1-15-dev-does-not-work/25009/7

I have not tried your or Randsad's method. Will try both tonight.

Thanks again for posting the workaround.
 
#20
@ab cd

Needed to reupload images as my old service wanted me to change my plan to have my photos on forum. In one side this is good as the uploaded images where from my home station and these ones are from office station

Don´t forget to tell me if the workaround worked.
 
Last edited:
Top