Dump1090 Program Parameters

luminoxs

New Member
Hello,

I followed the instructions instructions that ab cd made about installing Dump1090 and it works great. When it starts up, I want to add the parameter '--interactive' when it starts or how to start Dump1090 it manually. I can`t seem to figure it out. Any help would be appreciated!

Thanks in advance
 

Janos Konya

New Member
Maybe, a space shall be deleted between "--" and "interactive" in your parameter - if there is any.
Do not forget to use also the --net switch in the command line
./dump1090 --interactive --net
 
Last edited:

luminoxs

New Member
I am extremely new to Linux and can`t find the folder where that is in. I have also looked in /etc/rc.local to see if the auto run script is in there and it isn't. I've tried "sudo systemctl restart dump1090-mutability --interactive" and it says "systemctl: unrecognized option '--interactive'". Most of my online help points to "./dump1090 --interactive --net" but that doesn`t do anything.
 

ab cd

Senior Member
First stop currently running dump1090-mutability to free the dongle
Code:
[email protected]:~ $ sudo systemctl stop dump1090-mutability

Now run dump1090-mutability in interactive mode
Code:
[email protected]:~ $ dump1090-mutability --interactive

This is the output:
Code:
Wed Nov 18 01:23:43 2020 EST  EB_SOURCE EB_VERSION starting up.
Using sample converter: UC8, integer/table path
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00001090 (currently selected)
Detached kernel driver
Found Rafael Micro R820T tuner
Max available gain is: 49.60 dB
Setting gain to: 49.60 dB
Gain reported by device: 49.60 dB
Allocating 15 zero-copy buffers

 Hex    Mode  Sqwk  Flight   Alt    Spd  Hdg    Lat      Long   RSSI  Msgs  Ti|
-------------------------------------------------------------------------------
 C02067 S                      100                             -25.6     3 10
 200200 S                    20100                             -24.5     3  0
 AD9A70 S     0514  MAL8062  13400  385  080   43.851  -79.360 -18.7   177  0
 06A2AF S     0702  QTR8854  36000  505  213   43.946  -77.410 -17.6   112  0
 

luminoxs

New Member
Thank you for your help but I'm halfway trying to achieve what I'm trying to do. I have a raspberry pi with a 3.5 inch touch screen LCD hat. I am trying to get the "--interactive" to display on the hat and have the map. When I auto start the program in /etc/rc.local with "dump1090-mutability --interactive" I get the the interactive data on the hat but "Problem fetching data from dump1090. AJAX call failed (error: Not Found). Maybe dump1090 is no longer running? The displayed map data will be out of date." on the map. When I add "--net" to make it "dump1090-mutability --interactive --net" I get the same error code on the map. If I remove "dump1090-mutability --interactive --net" from rc.local and use "sudo dpkg-reconfigure dump1090-mutability" to auto start, the maps works great but I don't get data shown on the hat.

The other question I have is there a way to make the Pi a "access point" for me to connect to it other than going through a router to get the data from dump1090? I would like to use this out into the field and have a map on my laptop or tablet without a use of a router.
 

Janos Konya

New Member
You can share the "Internet" connection of your laptop by using an extra USB to Network Adapter
(use as a last option if you want to keep the function of the original - wired - adapter)

After setting the internet sharing on your laptop, the connected pi will get an IP address from your laptop directly - so you can reach it without a router. Your laptop will behave as a gateway. Having a wireless Internet connection, feeding is also possible.

It is possible to use the original ethernet connector to share the Internet if wifi adapter is your primary to reach the world outside...
In mobil use, you can use a power-pack for the pi.

Of course, the pi connected directly needs the laptop always switched on. Take care of restricting the sleep function as well.
(laptop should not switch the shared adapter off)

If you share your internet connection on your phone for the wifi adapter of the laptop, you can have the online maps and functions too, while you are out of a building.
 
Last edited:

ab cd

Senior Member
view1090-mutability

Run view1090-mutability without stopping dump1090-mutability.
As dump1090-mutability will be running normally, you will see a normal map.

(1) The most basic usage of view1090-mutability is with no flags. The view1090-mutability will connect to the dump1090-mutability running on the RPi, and display the decoded messages in an ASCII-text table, as shown below:
Code:
[email protected]:~ $ view1090-mutability

Hex    Mode  Sqwk  Flight   Alt    Spd  Hdg    Lat      Long   RSSI  Msgs  Ti|
-------------------------------------------------------------------------------
8990E2 S                    32000                             -25.2    12  1
A99D89 S     2331  AAL9716  37000  531  056   42.746  -78.774 -21.7    35  1
0D0B14 S                           241  064                   -26.0     2  9
89902F S                    26250  424  328                   -28.5     4  3
AD9A70 S     0556  MAL8062  20225  480  072   43.757  -78.834 -16.5    97  1


(2) If view1090-mutability is used with flag --no-interactive, the view1090-mutability will connect to the dump1090-mutability running on the RPi, but will disable interactive mode, and print messages to stdout

Code:
[email protected]:~ $ view1090-mutability --no-interactive

*8d0d0b14581120d188ec2c883011;
CRC: 000000
RSSI: -18.6 dBFS
Time: 408557315.58us
DF:17 AA:0D0B14 CA:5 ME:581120D188EC2C
Extended Squitter Airborne position (barometric altitude) (11)
  ICAO Address:  0D0B14 (Mode S / ADS-B)
  Air/Ground:    airborne
  Altitude:      2250 ft barometric
  CPR type:      Airborne
  CPR odd flag:  even
  CPR NUCp/NIC:  7
  CPR latitude:  (26820)
  CPR longitude: (60460)
  CPR decoding:  none

*8d0d0b14990c488ac814822e4b7b;
CRC: 000000
RSSI: -18.6 dBFS
Time: 408738763.50us
DF:17 AA:0D0B14 CA:5 ME:990C488AC81482
Extended Squitter Airborne velocity over ground, subsonic (19/1)
  ICAO Address:  0D0B14 (Mode S / ADS-B)
  Air/Ground:    airborne
  GNSS delta:    -25 ft
  Heading:       221
  Speed:         110 kt groundspeed
  Vertical rate: -256 ft/min barometric


All Parameters of "view1090-mutability"
Code:
[email protected]:~ $ view1090-mutability --help
-----------------------------------------------------------------------------
| view1090 ModeS Viewer                                EB_SOURCE EB_VERSION |
-----------------------------------------------------------------------------
--no-interactive         Disable interactive mode, print messages to stdout
--interactive-rows <num> Max number of rows in interactive mode (default: 15)
--interactive-ttl <sec>  Remove from list if idle for <sec> (default: 60)
--interactive-rtl1090    Display flight table in RTL1090 format
--modeac                 Enable decoding of SSR modes 3/A & 3/C
--net-bo-ipaddr <IPv4>   TCP Beast output listen IPv4 (default: 127.0.0.1)
--net-bo-port <port>     TCP Beast output listen port (default: 30005)
--lat <latitude>         Reference/receiver latitide for surface posn (opt)
--lon <longitude>        Reference/receiver longitude for surface posn (opt)
--max-range <distance>   Absolute maximum range for position decoding (in nm, default: 300)
--no-crc-check           Disable messages with broken CRC (discouraged)
--no-fix                 Disable single-bits error correction using CRC
--fix                    Enable single-bits error correction using CRC
--aggressive             More CPU for more messages (two bits fixes, ...)
--metric                 Use metric units (meters, km/h, ...)
--show-only <addr>       Show only messages from the given ICAO on stdout
--help                   Show this help
 
Last edited:

ab cd

Senior Member
Would you know I can get view1090-mutability to run at startup?

You can get it run at startup by file rc.local as follows:

(1) Open file for editing
Code:
sudo nano /etc/rc.local

(2) Scroll down, and just above the last line (i.e. just above exit 0), add following line:
EDIT: Added "sleep 10" as advised by luminoxs
Code:
sleep 10; view1090-mutability

(3) Save file (Ctrl+O) and close (Ctrl+X)

(4) REBOOT PI


Please note that view1090-mutability starts in interactive mode without flag --interactive.
 
Last edited:

luminoxs

New Member
I finally got it to work and want to thank you for your help. At first the instructions above wasn't working and thought that maybe it was trying to run view1090-mutability before dump1090-mutability could load. I went and googled wait commands for rc.local and came up with this.

(sleep 5

view1090-mutability) &

That 5 second delay was enough time to start view1090 and have it displayed on my pi display hat.
Thanks again for your guys help!
 

ab cd

Senior Member
Thanks for advising to add "sleep 5".
One of my Pi worked OK with 5 seconds delay, but other Raspbian's response was slower and "sleep 5" did not work for it, so I had to increase it to "sleep 10".

I have edited my post and the line to be added just above last line (i.e. just above exit 0) in the file rc.local is now the one shown below.
Tested, found works OK.
Code:
sleep 10; view1090-mutability
 
Last edited:
Top