modesdeco2 on Pi b+ Illegal instruction

#1
Hi All,
In the dim and distant past I had modesdeco2 working on Pi 2 it died some time ago and i finally dusted off my old B+ Pi and loaded the latest Noobs which reports to be :
pi@raspberrypi:~/modesdeco2 $ lsb_release -da
No LSB modules are available.
Distributor ID: Raspbian
Description: Raspbian GNU/Linux 8.0 (jessie)
Release: 8.0
Codename: jessie

I down loaded the build for Jessie Pi 2 ( I have actually tried all the Pi builds out of desperation!) but when i try to run it i get:
pi@raspberrypi:~/modesdeco2 $ ./modesdeco2
Illegal instruction

I have also tried :
pi@raspberrypi:~ $ /home/pi/modesdeco2/modesdeco2 --rbs --gain 49.6 --web 8081 --beast 31001 --sbs10001 30003 --db /home/pi/modesdeco2/BaseStation.sqb --silhouettes /home/pi/modesdeco2/silhouettes --location 52.741:0.450 &
[1] 866

which is how i used to run it.

But I don't know enough to diagnose why I can't connect to it on port 8081, is it running?
I can ping the IP of the Pi so that's ok...
but trying to connect to it on http://192.168.1.215:8081/ I get "refused to connect"

Have I missed something here?
 
Top