Plane Finder Client New Version! 3.4.25

Lee Armstrong

Administrator
Staff member
Hello Andreas,

We only publish the changes for major release and so the release notes for 3.7.x apply to all.

There have only been two releases since 3.7.1 and they only included fixes for the Radarcape receivers and also users in China. We only push out if there is a need.

In your case 3.7.20 to 3.7.40 there was nothing changed.

Lee
 

Andreas Warburton

New Member
Thanks a lot, Lee, for your super quick reply! Regarding the auto-update capability, would you be able to point me to how that is implemented in PF? For example, the FR24 folks use a script in /etc/cron.d

I think my pf auto-update capability is absent, so would like to troubleshoot it if possible.

Many thanks,
Andreas
 

Lee Armstrong

Administrator
Staff member
Yes we wanted to keep out very simple as have seen issues with other clients and their updates and big issues!

3.7.40 was released on 22/01 but like I say it only had fixes for users in China. 3.7.20 was fixes for Radarcape V2 firmware and that was last May 2017.
 

Andreas Warburton

New Member
Got it, and understood now, thank you kindly! I, and I'm sure many of my fellow feeders, are grateful for the stability of your software. Thank you for your answers/support.

Best,
Andreas
 

Lee Armstrong

Administrator
Staff member
4.1.1 includes Google Maps for now.

Please try not to use older versions as at some point the get blocked on our systems
 

ab cd

Senior Member
4.1.1 includes Google Maps for now.
I checked again, and found v 4.1.1 is DUAL mode.
By default Open Street Map, but can be switched to Google Map.


Please try not to use older versions as at some point the get blocked on our systems
Delted v 3.7.40 from this post:

https://forum.planefinder.net/threads/raspberry-pi-b-rpi2-rpi3-installation-instructions-for-raspbian-dump1090-data-feeder.241/post-2451

Also there are following two additional features compared to v 3.7.40
(1) Range Ring
(2) Polar Curve


OPEN STREET MAP
PFClient 4.1.1-Open Street.png



GOOGLE MAP
PFClient 4.1.1-Google.png
 
Last edited:

ab cd

Senior Member
Hi Lee,
Do I need to remove the 3.7.40 if I want to upgrade to 4.1.1?
On one of my Pi I removed 3.7.40, then installed 4.1.1
Code:
sudo dpkg --purge pfclient

wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb
sudo dpkg -i pfclient_4.1.1_armhf.deb
On other Pi, I simply installed 4.1.1 over 3.7.40

Code:
wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb
sudo dpkg -i pfclient_4.1.1_armhf.deb
Both the methods work ok.
 

FUNG SAI HOU

New Member
On one of my Pi I removed 3.7.40, then installed 4.1.1
Code:
sudo dpkg --purge pfclient

wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb
sudo dpkg -i pfclient_4.1.1_armhf.deb
On other Pi, I simply installed 4.1.1 over 3.7.40

Code:
wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb
sudo dpkg -i pfclient_4.1.1_armhf.deb
Both the methods work ok.
Hi ab cd,

Yes, thanks for the info. I simply overwrite it with just the method you shared to me.

It looks good, very good improvement for Planefinder. Well Done.

Regards,
Sai Hou
 

FUNG SAI HOU

New Member
I found out that Planefinder (pfclient 4.1.1), the polar range chart will not update automatically. The down side of this new update is, it will not save the polar range chart. If it can be saved. then it would be nice.
 
Last edited:

Lee Armstrong

Administrator
Staff member
Which polar chart on which map?
Are there any errors in the JavaScript console at all in the browser?
Also can you tell me the browser and operating system you are using to access it please?

We have never saved the polar chart on the device, if you want it saved then please visit the website which stores this.
 

FUNG SAI HOU

New Member
Which polar chart on which map?
Are there any errors in the JavaScript console at all in the browser?
Also can you tell me the browser and operating system you are using to access it please?

We have never saved the polar chart on the device, if you want it saved then please visit the website which stores this.
Hi Lee,

Thanks for the reply.

I am using Google Chrome, Windows 7 X64. The polar range chart will not auto update the range plot.

polar range chart 01.png


http://IP:30053/map.html

Look at the AXM6263, flight is there but the range will not plot automatically.

Regards,

Sai Hou
 
Top