Raspberry Pi (B+, Zero, RPi2, RPi3 & RPi4) - Installation instructions for Raspbian, Dump1090 & Data Feeder

Rueganer91

New Member
of the cache ...
in the pf client say in the terminal :
we were unable to locate a configuration file and have entered configuration mode by default . Please visit http:// 192.168.17.8.00:30053

edit : after 3 hours search and configure its works ... As I have done, I do not know :(
 

ColinXSD

New Member
I have a problem with my Data not feeding to planefinder, my system can have one of two different IP addresses, so if my Pi gets the one that isn't assigned to Planefinder my Data doesn't get out.

I feed data to other places which don't have this problem, can it be fixed to automatically find the right address like the others?
 

Lee Armstrong

Administrator
Staff member
I have a problem with my Data not feeding to planefinder, my system can have one of two different IP addresses, so if my Pi gets the one that isn't assigned to Planefinder my Data doesn't get out.

I feed data to other places which don't have this problem, can it be fixed to automatically find the right address like the others?
What shows up in the log of the client? We don't lock to an IP.
 

ColinXSD

New Member
This mornings Log:

2017-08-05 07:37:13.262047 [-] Successfully sent 86 aircraft updates across 10 packets (11.00KB)
2017-08-05 07:35:24.984443 [-] Successfully sent 28 aircraft updates across 10 packets (6.00KB)
2017-08-05 07:34:42.351701 [-] TCP connection established: 192.168.0.33:300052017-08-05
07:34:42.351092 [-] Client restarted successfully2017-08-05 07:34:42.120407 [-] Restarting due to configuration change
2017-08-05 07:31:59.335384 [-] Client restarted successfully2017-08-05
07:31:59.335337 [-] Failed TCP connection to all provided addresses for: 192.168.0.36:300052017-08-05
07:31:56.441124 [-] Received a restart request, restarting...2017-08-05
07:31:51.175290 [-] Failed TCP connection to all provided addresses for: 192.168.0.36:300052017-08-05
07:31:43.15273 [-] Failed TCP connection to all provided addresses for: 192.168.0.36:300052017-08-05
07:31:34.855385 [-] Failed TCP connection to all provided addresses for: 192.168.0.36:30005

as you can see it depends what IP address is selected as to whether it connects or not.
I have to manually change the IP in the setup to match what the Pi is currently using.
 

Lee Armstrong

Administrator
Staff member
Looks like you've configured it to a fixed IP and that IP can change with DHCP. If this is installed on that very same Pi change the IP to 127.0.0.1 and it will work even if the IP changes.

Either that or give it a static reservation in your DHCP scope. If you do this you won't have to hunt around for the IP when you want to access the web interfaces of the client.
 

ColinXSD

New Member
Thanks Lee, changing to 127.0.0.1 worked.
I don't remember setting up a static IP originally, it just seemed to pick the address I was using at the time.

Colin.
 

ga_dude626

New Member
Hi ab cd,

Thanks for the great instructions! I got through them on Aug 5, 2018 and it works like a charm!

Thanks again!
 

mobisat

New Member
DUMP1090-MUTABILITY

Instead of dump1090, you can install dump1090-mutability which has more functionality.

DO NOT to install both versions of dump. Install either dump1090 OR dump1090-mutability.


1. Download installation package, and install it:
Code:
wget https://github.com/mutability/dump1090/releases/download/v1.14/dump1090-mutability_1.14_armhf.deb
sudo dpkg -i dump1090-mutability_1.14_armhf.deb
The above Version is current as on Feb 06, 2018
I get as far as that and I have a dependency error, Package librtlsdr0 is not installed.
I had to run to run sudo apt-get install librtlsdr0 to get it to work, so can this be added to the tutorial?
 

Attachments

Last edited:

ab cd

Senior Member
I get as far as that and I have a dependency error, Package librtlsdr0 is not installed.
I had to run to run sudo apt-get install librtlsdr0 to get it to work, so can this be added to the tutorial?
Thanks for the information. I have not used this method with latest version of Raspbian. It worked ok with older versions. With which version of Raspbian you faced this problem? I will have to try it myself first to see what happens and why.
 

mobisat

New Member
I used the one below. I also found and used the 1.1.5~dev version of dump1090-mutability, all working great.

Raspbian Stretch Lite

Minimal image based on Debian Stretch

Version: November 2018

Release date: 2018-11-13

Kernel version: 4.14
 

ab cd

Senior Member
I used the one below. I also found and used the 1.1.5~dev version of dump1090-mutability, all working great.
The dump1090 (Malcom Robb) still uses Google map, which has recently started displaying water marks and a darkened map, unless one obtains a Google key, which requires a Credit Card.

The dump1090-mutability version 1.15~dev uses Openstreet map, which does not require any key. One can add to it Bing Map layer, which requires a Bing Map API key, but it is free and easy to obtain. No credit card required.


How to Install dump1090-mutability_1.15~dev on RPi

.
.
 
Last edited:
Top