Trial Run Results for Three Types of Whip Antennas

AnirbanSen

Member
I forgot to add some essential details.
The radial wires are 18 SWG equally spaced 8 in number. They are roughly 67mm (+/- 1mm) from the bent and bent at 45 degrees (as per eye estimate). The center conductor is from the RG6 which I think is close to 1mm width and is 64mm (+/- .5mm).

I am close to a busy airport (about 10-12 Km as the crow flies) so I can see quite a number of flights. With the DVB stock antenna (not shortened yet), my feed is at https://www.flightradar24.com/account/feed-stats/?id=14056

Since I am on the 4th floor of my building (roof is at 8, and at 8+1), my vision is admittedly severely limited. The next building is 20 ft away!!! But the purpose of my antenna now is to see how good it performs even under these limited circumstances after which I may put them on the roof.

I am not sure what kind of antenna will survive on the roof without regular maintenance. That may or may not be feasible with all types of antenna. Also, there is no available electrical supply on the roof. (I am using a powerbank for testing when I go up there). Only a portion of the 8th floor roof is within my Wifi Range. If I want a 360 view, I have to access the 8+1 roof, but that has no Wifi. I may have to figure out if I can keep the antenna on the 8+1 and the unit in an IP66 shell on Floor 8 and use an RG6 or LMR 400 for this in between space. I could possibly send up power supply up the wall and use a DC to DC buck convertor for the %v input. I'd rather not invest in a Pi 3B+ with powerhat because of possible theft issues, etc.

My main focus right now is to test and build a robust antenna.

P.S.: Graphs attached. Right now, back to stock antenna.
 

Attachments

wiedehopf

Member
As for the antenna.

As i wrote before there must be a connection break in your coax cable or adapter.
Can you make a photo of how you connect to the dongle?
 

AnirbanSen

Member
Now using dump 1090 v1. 14 I believe.
The plan was to fix the antenna and then setup a fresh sd card with Debian stretch (lite/full) and then all the feeds.

Right now I am struggling to get the Pi 0 to switch automatically between 2 Wifis. Apparently, setting priority in the WPA_supplicant and ifconfig down/up won't help.

As for the antenna, I took it down and removed the joints. The rg6 ran 7m from the antenna end to a direct wire joint to a rg176 to connect to an mcx which then connected to the dvb.

A pic of the last 10cm is here. I tested the center as well as the radial length with a multimeter and there was no line break at least. The signal loss could have been significant.

I'll update the dvb mode and 1090 dump tomorrow. Today I plan to use a cell wifi on the roof and see the range.
 

Attachments

AnirbanSen

Member
I figured as much.
The MCX is quite hard to connect a wire to.
I've ordered a MCX to SMA cable but these things come directly from China and may or may not actually land up.

Earlier, the joint between the coaxial RG6 and rg176 was through a female SMA - female SMA and f connectors. Am trying to find something which allows a rg6 to directly connect to the DVB MCX.

US $0.66 13%OFF | SMA Female To MCX Male Plug Straight RF Coaxial Adapter Connector Converter Drop Ship De26

This has been ordered. No idea when it'll come.
 

wiedehopf

Member
I'm not sure how well shoving RG6 into that female SMA adapter is going to work.
Compared to the other contraption it's probably an upgrade.

You'll know when you have reached an improvement compared to the whip antenna i guess :)
Good luck, with those resources you'll need it, 1090 MHz wants proper connections.
 

AnirbanSen

Member
True. I'll need a few factory made parts. At these frequencies, need to eliminate all extra wires, joints and connectors.

Worth trying out the SO239 8 legged spider?
The RG6 to DVB will still be a problem.
 

AnirbanSen

Member
That was the graph generated from the roof before the dump1090 update.

DVB is now running in Beast mode. Have also installed dump1090-fa.

But the graphs aren't working right now. Tried to reinstall from https://github.com/wiedehopf/graphs1090#graphs1090

Bunch of errors like:
File /var/lib/collectd/rrd/localhost/dump1090-localhost/dump1090_messages-remote_accepted.rrd not found! Associated graph will be empty!
 

Attachments

Last edited:

ab cd

Senior Member
You have to:
  1. Join core of RG6 to core of RG176 cable
  2. Join braid of RG6 to braid of RG176 cable
  3. Insulate core joint by a tape so that it does not touch the braid and does not create a short.

Hack coax joint (RG6 to RG174) in my FIRST receiver 2013 (Click here)
2839




 
Last edited:

AnirbanSen

Member
Thanks for the pic. I hadn't used foil to cover the joint since I had used a sma-sma Connector. Had to solder the centre lead of the rg176 since it's not a single core wire. For the sheathing, I had used a zip tie since it is considerably narrower than the f Connector.
 
Last edited:

wiedehopf

Member
Don't mind the errors.

Do a reboot, wait 2 minutes and do another reinstall.
It should detect the changed webaddress to access the stats.json.
 

AnirbanSen

Member
Didn't work!
Graphs are still inaccessible.
Also, cant seem to load http://localhost/dump1090-fa.

However, when I tried to reinstall dump1090-fa, I got the message it is already the newest version (3.7.1)

Do I need to install rrd?

Worth a full purge and retry?
 

wiedehopf

Member
I think i see the problem with my commands one of them fails.

Try this :)

sudo apt purge dump1090-mutability
sudo apt purge dump1090
sudo lighty-disable-mod dump1090
sudo reboot

Also please do
cat /etc/fr24feed.ini
to verify it says beast-tcp as receiver-type
and bs and raw are set to no.
 

AnirbanSen

Member
I've uninstalled graphs1090.

Above commands confirmed packaged did not exist.
libdbil and librrd8 packages weren't removed though.

I shall reinstall graphs1090 again.
 

wiedehopf

Member
Yeah you might have to look at some logs to figure out what's wrong.
Probably it's only the webserver who is not running correctly, so check:

sudo journalctl -u lighttpd --no-pager

If it's not working there should be some error, if you would copy and paste it to a message here i can take a look.
 

wiedehopf

Member
It seems you didn't use this command:
sudo lighty-disable-mod dump1090

Or maybe you did and it didn't work?
This command should do the trick then.

sudo rm /etc/lighttpd/conf-enabled/89-dump1090.conf

You can restart lighttpd and everything should hopefully work:
sudo systemctl restart lighttpd
 
Last edited:

AnirbanSen

Member
For whatever reason, I had to manually go into the directory and rm the file.
Reinstalled Graphs1090 and finally its working.

MANY THANKS for this segment of the help.

In the current state, ADS-B signal level is around -12db which if I am not incorrect would go to show the efficiency of the antenna being used and the LOS location of the antenna. I will send a screenshot once I try again on the roof.

In the meantime, how best to see tracked aircrafts on a map? I believe there is an openstreetmap API now?
 

wiedehopf

Member
-12dB is actually quite a good signal, could you show the graph?
(you can just right click and save the image, no need to put it in a pdf :) )

doesn't http://pi/dump1090-fa work for the map part?
 
Last edited:
Top