Trying to feed to PlaneFinder

bvb40170

New Member
Hi! I've got a Raspberry Pi 3b feeding FlightAware and Flightradar 24 and I would like to feed to Planefinder also.
I connected to my RPi by SSH, copied and pasted the link (wget http:// client etc) successfully, or so it would appear
but when I tried to unpack and install the pf client, this is what I got:

pi@img-2.1-7a621c:~$ sudo dpkg -i pfclient_4.1.1_armhf.deb
> Selecting previously unselected package pfclient.
> dpkg: unrecoverable fatal error, aborting:
> files list file for package `rpd-icons' contains empty filename

I've tried it several times both via SSH and direct on to my RPi but I cannot get beyond the above
error. Can anyone tell me where I'm going wrong?
Many thanks
 

wiedehopf

Member
Try:

Code:
sudo apt update
sudo apt upgrade
wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb -O pfclient.deb
sudo dpkg -i pfclient.deb

That likely won't help.
Try this instead:
Code:
sudo rm /var/lib/dpkg/info/rpd-icons.list
sudo apt --reinstall install rpd-icons
Then do the first thing i proposed :)
 

bvb40170

New Member
Thanks. Your first suggestion didn't work as you guessed.
Entering the first line of code sudo rm /var etc only locks up the console and goes nowhere.
Any other ideas?
Thanks
 

bvb40170

New Member
Eventually I got this error response

rm: cannot remove ‘/var/lib/dpkg/info/rpd-icons.list’: No such file or directory

Does this help with the analysis?
 
Top