x86_64 version?

Saturnus

New Member
Will have to investigate if setting that up in Docker can be done clean and small. It was in my head, but indeed not the preferred route.
 

ab cd

Senior Member
How to run pfclient_4.1.1_i386 on 64-bit system

The pfclient_4.1.1_i386 fails to run on 64-bit OS as the 32-bit C library is missing on 64-bit systems.

To install this library, run the following command.

64-bit Debian or Ubuntu :
sudo apt-get install libc6-i386

64-bit Fedora :
sudo dnf install audit.x86_64 glibc.i686 glibc.x86_64

64-bit OpenSUSE :
sudo zypper install glibc-32bit

64-bit ArchLinux :
sudo pacman -Syu lib32-glibc
sudo pacman -Syu lib32-gcc-libs
sudo ldconfig


Tested pfclient_4.1.1_i386 on following x64_86 OS

(1) Ubuntu
(2) OpenSUSE
(3) Fedora
(4) ArchLinux



(1) UBUNTU
Code:
abcd@ubuntu:~$ wget -O pfclient_4.1.1_i386.tar.gz http://client.planefinder.net/pfclient_4.1.1_i386.tar.gz
abcd@ubuntu:~$ sudo tar zxvf pfclient_4.1.1_i386.tar.gz
pfclient

abcd@ubuntu:~$ ./pfclient
-bash: ./pfclient: No such file or directory

abcd@ubuntu:~$ file pfclient
pfclient: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=f4824803948a0f21aab3c2161ea72f7ee4581754, with debug_info, not stripped

## WORKAROUND
abcd@ubuntu:~$ sudo apt-get install libc6-i386

abcd@ubuntu:~$ ./pfclient
2019-12-06 17:24:08.242137 [-] We were unable to locate a configuration file and have entered configuration mode by default. Please visit: http://192.168.0.15:30053 to complete configuration.
2019-12-06 17:24:08.267849 [-] Web server is now listening on: http://192.168.0.15:30053
2019-12-06 17:24:08.280797 [V] Performing NTP sync (3.planefinder.pool.ntp.org)...
2019-12-06 17:24:08.301363 [-] Echo port is now listening on: 192.168.0.15:30054
2019-12-06 17:24:08.486759 [V] NTP sync succeeded with settings:
2019-12-06 17:24:08.488000 [V]  Stratum: 2
2019-12-06 17:24:08.488813 [V]  System clock time: 1575653048.4868
2019-12-06 17:24:08.488907 [V]  Corrected clock time: 1575653048.4931
2019-12-06 17:24:08.489296 [V]  NTP offset: 0.0063s

(2) OpenSUSE
Code:
abcd@linux-gpce:~> wget -O pfclient_4.1.1_i386.tar.gz http://client.planefinder.net/pfclient_4.1.1_i386.tar.gz
abcd@linux-gpce:~> sudo tar zxvf pfclient_4.1.1_i386.tar.gz
pfclient

abcd@linux-gpce:~> ./pfclient
-bash: ./pfclient: No such file or directory

abcd@linux-gpce:~> file pfclient
pfclient: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-, for GNU/Linux 2.6.32, BuildID[sha1]=f4824803948a0f21aab3c2161ea72f7ee4581754, with debug_info, not stripped

## WORKAROUND
abcd@linux-gpce:~> sudo zypper install glibc-32bit

abcd@linux-gpce:~> ./pfclient
2019-12-06 17:54:47.523179 [-] We were unable to locate a configuration file and have entered configuration mode by default. Please visit: http://192.168.0.16:30053 to complete configuration.
2019-12-06 17:54:47.530168 [-] Echo port is now listening on: 192.168.0.16:30054
2019-12-06 17:54:47.539852 [V] Performing NTP sync (0.planefinder.pool.ntp.org)...
2019-12-06 17:54:47.531657 [-] Web server is now listening on: http://192.168.0.16:30053
2019-12-06 17:54:47.763751 [V] NTP sync succeeded with settings:
2019-12-06 17:54:47.764664 [V]  Stratum: 2
2019-12-06 17:54:47.766391 [V]  System clock time: 1575654887.7637
2019-12-06 17:54:47.773268 [V]  Corrected clock time: 1575654887.7637
2019-12-06 17:54:47.773381 [V]  NTP offset: -0.0000s

(3) FEDORA
Code:
[abcd@fedora ~]$ wget -O pfclient_4.1.1_i386.tar.gz http://client.planefinder.net/pfclient_4.1.1_i386.tar.gz
[abcd@fedora ~]$ sudo tar zxvf pfclient_4.1.1_i386.tar.gz
pfclient

[abcd@fedora ~]$ ./pfclient
-bash: ./pfclient: No such file or directory

[abcd@fedora ~]$ file pfclient
pfclient: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=f4824803948a0f21aab3c2161ea72f7ee4581754, with debug_info, not stripped

## WORKAROUND
[abcd@fedora ~]$ sudo dnf install audit.x86_64 glibc.i686 glibc.x86_64

[abcd@fedora ~]$ ./pfclient
2019-12-06 18:19:41.375644 [-] We were unable to locate a configuration file and have entered configuration mode by default. Please visit: http://192.168.0.17:30053 to complete configuration.
2019-12-06 18:19:41.396257 [V] Performing NTP sync (2.planefinder.pool.ntp.org)...
2019-12-06 18:19:41.401947 [-] Echo port is now listening on: 192.168.0.17:30054
2019-12-06 18:19:41.410098 [-] Web server is now listening on: http://192.168.0.17:30053
2019-12-06 18:19:41.536053 [V] NTP sync succeeded with settings:
2019-12-06 18:19:41.536794 [V]  Stratum: 2
2019-12-06 18:19:41.539665 [V]  System clock time: 1575656381.5360
2019-12-06 18:19:41.540011 [V]  Corrected clock time: 1575656381.5321
2019-12-06 18:19:41.540078 [V]  NTP offset: -0.0040s

(4) ARCH-LINUX
Code:
[abcd@archlinux ~]$ sudo wget -O pfclient_4.1.1_i386.tar.gz "http://client.planefinder.net/pfclient_4.1.1_i386.tar.gz"
[abcd@archlinux ~]$ sudo tar zxvf pfclient_4.1.1_i386.tar.gz
pfclient

[abcd@archlinux ~]$ ./pfclient
-bash: ./pfclient: No such file or directory

[abcd@archlinux ~]$ file pfclient
pfclient: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=f4824803948a0f21aab3c2161ea72f7ee4581754, with debug_info, not stripped

## WORKAROUND
[abcd@archlinux ~]$ sudo pacman -Syu lib32-glibc lib32-gcc-libs
[abcd@archlinux ~]$ sudo ldconfig

[abcd@archlinux ~]$ ./pfclient
2019-12-06 18:32:15.933096 [-] We were unable to locate a configuration file and have entered configuration mode by default. Please visit: http://192.168.0.25:30053 to complete configuration.
2019-12-06 18:32:15.946236 [!] Echo port failed to start with error: Address already in use (errno: 98)
2019-12-06 18:32:15.948012 [-] Echo port is shutting down
2019-12-06 18:32:15.946726 [!] Web Server failed to start with error: Address already in use (errno: 98)
2019-12-06 18:32:15.949658 [-] Web server is shutting down
2019-12-06 18:32:15.946976 [V] Performing NTP sync (0.planefinder.pool.ntp.org)...
2019-12-06 18:32:16.102662 [V] NTP sync succeeded with settings:
2019-12-06 18:32:16.103459 [V]  Stratum: 2
2019-12-06 18:32:16.105074 [V]  System clock time: 1575657136.1027
2019-12-06 18:32:16.106405 [V]  Corrected clock time: 1575657138.1246
2019-12-06 18:32:16.107337 [V]  NTP offset: 2.0219s
 
Last edited:

mignz

New Member
On Debian/Ubuntu also install libc6-dev-i386 to avoid the libgcc_s.so.1 must be installed for pthread_cancel to work error.
 

ab cd

Senior Member
Last edited:
Top